Вопрос по информатике:
На Паскале!!! Срочно!!!! Написать программу которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 2. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом (0-признак окончания ввода, не входит в последовательность).Количество чисел не превышает 1000. Введённые числа не превышают 30000.Программа должна вывести одно число:сумму чисел кратных 6 и оканчивающихся на 2. Также составить блок-схему, написать контрольные примеры и порядок выполнения работы.
- 27.07.2018 07:50
- Информатика
- remove_red_eye 8395
- thumb_up 51
Ответы и объяснения 1
var a, s: integer;
begin
s:=0;
readln(a);
while a0 do
begin
if (a mod 6=0) and (a mod 10=2) then
s:=s+a;
readln(a);
end;
writeln(s);
end.
- 28.07.2018 07:13
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.