Вопрос по информатике:
Напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 6 или 11. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).
Количество чисел не превышает 1000. Введённые числа не превышают
30 000.
Программа должна вывести одно число: количество чисел, кратных 6 или 11.
- 11.06.2016 23:39
- Информатика
- remove_red_eye 3097
- thumb_up 19
Ответы и объяснения 1
N = 30;
var
a:array [1..N] of longint;
I, j, k: longint;
begin
for i:=1 to N do
Readln(a[i]);
k:=0
for i:=0 to N do
begin
if (a[i]mod6=0) or (a[i]mod11=0) and (a[i]0) then
inc(k);
writeln(k)
- 12.06.2016 11:55
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.