Вопрос по информатике:
Дана непустая последовательность натуральных чисел, за которой следует 0. Составить программу поиска в данной непустой последовательности порядкового номера наибольшего элемента.
(Использовать while!!!)
HELP PLEASE!!
- 16.04.2016 00:46
- Информатика
- remove_red_eye 11932
- thumb_up 25
Ответы и объяснения 1
var x,max,n,k:integer;
begin
x:=-1;
max:=-1;
n:=0;
k:=0;
while x0 do
begin
readln(x);
k:=k+1;
if x>max then begin max:=x; n:=k; end;
end;
writeln(n);
end.
- 16.04.2016 11:08
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.