Вопрос по информатике:
Помогите решить задачу по программированию, пожалуйста!!
Используя,
а) оператор ветвления
б) оператор цикла
написать программу нахождения наибольшего из пяти чисел, вводимых с клавиатуры.
Pascal
- 03.08.2018 14:08
- Информатика
- remove_red_eye 16174
- thumb_up 50
Ответы и объяснения 1
Var a,b,c,d,e:integer;
Begin
Writeln('Введите значения переменных');
Readln(a,b,c,d,e);
If (a>b) and (a>c) and (a>d) and (a>e) tnen
Writeln('Наибольшее из 5 чисел ', a)
Else
If (b>a) and (b>c) and (b>d) and (b>e) tnen
Writeln('Наибольшее из 5 чисел ', b)
Else
If (c>a) and (c>b) and (c>d) and (c>e) tnen
Writeln('Наибольшее из 5 чисел ', c)
Else
If (d>a) and (d>b) and (d>c) and (d>e) tnen
Writeln('Наибольшее из 5 чисел ', d)
Else
Writeln('Наибольшее из 5 чисел ', e);
End.
Циклический алгоритм
Type
Vector=array [1..10] of integer;
Var m:integer;
a:vector;
i:byte;
Begin
Writeln('Введите значения переменных');
For i:=1 to 5 do
Readln (a[i]);
For i:=1 to 5 do
If a[i]>a[i+1] then
m:=a[i];
Writeln('Наибольшее число ', m);
End.
- 04.08.2018 19:42
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.