Вопрос по информатике:
Написать программу в С++. Задан двумерный массив Y из 7-и строк и 3-х столбцов. Составить программу, которая вычисляет значение суммы произведений элементов строк
- 05.02.2018 10:32
- Информатика
- remove_red_eye 12854
- thumb_up 14
Ответы и объяснения 1
#define M 3
#include
using namespace std;
int main() {
float Y[N][M];
// Ввод данных
for (int i = 0; i < N; i++)
for (int j = 0; j < M; j++)
cin >> Y[i][j];
float sum = 0, prod = 0;
for (int i = 0; i < N; i++) {
prod = 1;
for (int j = 0; j < M; j++) {
prod *= Y[i][j];
}
sum += prod;
}
cout << "Sum: " << sum << ".\n";
return 0;
}
- 06.02.2018 05:11
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.