Вопрос по информатике:
Напишите программу, реализующую игру на угадывание целого числа от 1 до 10. Угадываемое число определяется случайно, пользователь вводит предполагаемое значение. Если число угадано, программа выводит набранные очки, а если нет-предлагает повторить попытку. Каждая безуспешная попытка снижает баллы. В начале игры назначается 10 баллов. Помогите, пожалуйста, составить программу... Сдать надо завтра. Пожалуйста))))))))
- 25.04.2018 17:02
- Информатика
- remove_red_eye 8779
- thumb_up 35
Ответы и объяснения 1
begin
b:=random(10)+1;
k:=10;
WriteLn('Привет, я задумал число от 1 до 10. Угадай его.');
while ab do
begin
Write('Введи число: ');
ReadLn(a);
if ab then
begin
WriteLn('Не угадал... Попробуй повторить попытку.');
k:=k-1
end
end;
WriteLn('Молодец! Угадал! Набранные очки: ',k)
end.
- 26.04.2018 02:56
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.