Вопрос по информатике:
Помогите составить программу на языке Паскаль с помощью Random
дано a[i]∈[-13,8]
Найти произведение нечетных отрицательных чисел
n=5
- 21.10.2015 07:23
- Информатика
- remove_red_eye 12206
- thumb_up 34
Ответы и объяснения 1
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(5,-13,8).Println.Where(t->(t<0) and t.IsOdd).ToArray;
if a.Count>0 then a.Aggregate(1,(i,j)->i*j).Println
else Writeln(0)
end.
Пример
-2 -6 -6 -7 -13
91
- 22.10.2015 03:19
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.