Вопрос по информатике:
Напишите программу, которая получает с клавиатуры номер месяца и выводит название соответствующего ему время года или сообщение об ошибке.
Пример:
Введите номер месяца:
5 . В программе ПАСКАЛЬ!!! Не использовать case
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 02.11.2015 09:54
- Информатика
- remove_red_eye 12238
- thumb_up 13
Ответы и объяснения 1
var
a: integer;
procedure Error;
begin
write('ERROR');
exit;
end;
begin
write('Введите номер месяца - ');
readln(a);
if (a 12) then
Error
else
if (a = 12) or (a = 1) or (a = 2) then
write('Зима')
else
if (a = 3) or (a = 4) or (a = 5) then
write('Весна')
else
if (a = 6) or (a = 7) or (a = 8) then
write('Лето')
else
if (a = 9) or (a = 10) or (a = 11) then
write('Осень');
end.
- 03.11.2015 19:27
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.