Вопрос по информатике:
Написать программу Pascal с помощью команд if then else. Есть прямоугольное отверстие с размерами а и b. Пройдет ли в это отверстие балка восотой m и шириной n
- 09.04.2018 00:27
- Информатика
- remove_red_eye 14040
- thumb_up 44
Ответы и объяснения 1
Выражение min(a,b) < min(m,n) ∧ max(a,b) < max(m,n) должно принимать значение "истина".
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!
begin
var (a,b):=ReadReal2('Введите через пробел размеры балки:');
var (m,n):=ReadReal2('введите через пробел размеры отверстия:');
if (Min(a,b)
else Writeln('Балка не проходит в отверстие')
end.
Пример
Введите через пробел размеры балки: 3.6 4.8
введите через пробел размеры отверстия: 4.2 4
Балка не проходит в отверстие
- 01.01.1970 00:00
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.