Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет сумму четных чисел , не кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется четное число , не кратное 3. Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число- сумму четных чисел, не кратных 3.
- 22.09.2017 22:46
- Информатика
- remove_red_eye 15582
- thumb_up 47
Ответы и объяснения 1
a,sum,i,n:integer;
Begin
Writeln('Введите количество чисел в последовательности');
Readln(n);
Writeln('Вводите числа');
For i:=1 to n do
begin
Readln(a);
If (a mod 2 = 0) and (a mod 3 0) then sum:=sum+ a;
end;
Writeln('Сумма четных чисел не кратных 3 = ', sum);
end.
- 23.09.2017 15:00
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.