Вопрос по информатике:
Написать программу ,которая с клавиатуры запрашивает размер двумерного массива найти и вывести на экран сумму значений элементов расположенных в левом верхнем углу матрицы и правом нижним???Pascal
- 27.03.2018 11:22
- Информатика
- remove_red_eye 6084
- thumb_up 31
Ответы и объяснения 1
Ну допустим что угол это одна самая угловая ячейка
var
a: array [1..20,1..20] of Integer ;
i,j,n,sum:Integer;
begin
Writeln('Введмте размер двумерного массива (2<=n<=20)');
ReadLn(n);
for i:=1 to n do
begin
for j:=1 to n do
begin
a[i,j]:=Random(20);
Write(a[i,j]:3);
end;
WriteLn();
end;
sum:=a[1,1]+a[n,n];
WriteLn('Сумма значений элементов расположенных в левом верхнем и в правом нижнем углах = ', sum);
end.
- 28.03.2018 09:06
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.