Вопрос по информатике:
№1
Дано четырехзначное число. Проверить, является ли оно палиндромом. Примечание: палиндромом называется число, слово или текст, которые одинакового читаются слева направо и справа налево. Например, в нашем случае это числа 1441, 5555, 7117 и т. д.
№2
Автоморфным числом называется число, равное последним цифрам своего квадрата. Например, 52=25, 252=625. Составить программу, которая определяет, являются ли числа автоморфными.
- 01.05.2016 23:56
- Информатика
- remove_red_eye 12868
- thumb_up 10
Ответы и объяснения 1
Внимание! Если программа не работает, обновите версию!
№1
begin
var a:=ReadInteger.ToString;
Writeln(a=a.Inverse)
end.
Примеры
2441
False
1991
True
№2
begin
var n:=int64(ReadInteger);
var s:=n.ToString;
var s2:=(n*n).ToString;
if s2.Right(s.Length)=s then Writeln('Афтоморф')
else Writeln('Не автоморф')
end.
Примеры
625
Афтоморф
1020
Не автоморф
- 02.05.2016 09:18
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.