Вопрос по информатике:
Написать программу которая сравнивает сумму четных значений с нечетными значением СРОЧНО РЕБЯТ!!!
- 26.07.2018 10:06
- Информатика
- remove_red_eye 756
- thumb_up 43
Ответы и объяснения 1
Внимание! Если программа не работает, обновите версию!
begin
var (so,se):=(0,0);
ReadSeqIntegerWhile(t->t>0).ForEach(t->if t.IsOdd then so+=t else se+=t);
Write('Сумма четных ',se,' ');
if se>so then Write('>')
else
if se=so then Write('=')
else Write('<');
Writeln(' суммы нечетных ',so)
end.
Пример
3245 6774 23241 5645 967 32234 123 65 2134 0
Сумма четных 41142 > суммы нечетных 33286
Программа считывает данные, пока они являются натуральными числами.
- 27.07.2018 01:55
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.