Вопрос по информатике:
Напишите программу, которая считывает произвольное количество чисел до стоп-слова "STOP" и выводит, сколько раз среди них встречается первое введенное число (включая первое вхождение).
Sample Input:
8
1
6
1
6
10
8
10
1
2
9
4
2
6
3
4
9
3
1
6
10
8
4
9
10
2
3
1
STOP
Sample Output:
3
- 26.09.2018 12:04
- Информатика
- remove_red_eye 16110
- thumb_up 51
Ответы и объяснения 1
Внимание! Если программа не работает, обновите версию!
begin
var s1:=ReadlnString;
if s1='STOP' then Writeln(0)
else begin
var k:=1;
ReadSeqStringWhile(t->t'STOP').ForEach(w->if w=s1 then k+=1);
Writeln(k)
end
end.
- 27.09.2018 21:24
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.