Вопрос по информатике:
С++
Напишите программу, которая заменяет во всей строке одну последовательность символов на другую.
Пример:
Введите строку:
(X > 0) and (Y < X) and (Z > Y) and (Z <> 5)
Что меняем: and
Чем заменить: &
Результат
(X > 0) & (Y < X) & (Z > Y) & (Z <> 5)
- 25.08.2018 01:47
- Информатика
- remove_red_eye 8408
- thumb_up 40
Ответы и объяснения 1
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64
#include
#include
using namespace std;
int main()
{
string str, from, to;
getline(cin, str);
cin >> from >> to;
size_t i = 0;
for (; (i = str.find(from, i)) != string::npos; i += to.length())
str.replace(i, from.length(), to);
cout << str;
}
- 26.08.2018 10:43
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.