Вопрос по информатике:
Надо на языке с++ решить эту задачу:
Пятиклассники на уроке информатики узнали, что четность и нечетность для
двоичных чисел в компьютере считается иначе. Четным считается двоичное число,
которое содержит четное количество единиц. Они решили придумать для
десятичных чисел свои правила четности и нечетности. Четным считается
десятичное число, у которого в записи четное число нечетных десятичных цифр.
Нечетной считается десятичная цифра в двоичной записи, которой содержится
нечетное количество единиц.
Требуется написать программу, которая поможет пятиклассникам вычислить
четные и нечетные числа.
- 15.09.2016 03:03
- Информатика
- remove_red_eye 17228
- thumb_up 41
Ответы и объяснения 1
int binary(int a){ int count = 0; while (a) { if (a%2 == 1 ) count++; a /= 2; } return count;}
int main(){ int a; std::cin>>a; if (binary(a)%2 == 0) std::cout<<"chetnoe"; else std::cout<<"Nechetnoe";}
- 16.09.2016 02:58
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.