Вопрос по информатике:
Напишите программу, которая для введенной десятичной дроби выполняет сдвиг десятичной точки на указанное число разрядов (позиций) вправо (если количество разрядов задано положительное) или влево (если количество разрядов задано отрицательное). язык Pascal
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 19.03.2017 12:10
- Информатика
- remove_red_eye 15327
- thumb_up 34
Ответы и объяснения 2
a:real;
begin
write('Введите число: ');
readln(a);
write('Введите число разрядов (позиций): ');
readln(r);
if(r>0) then for i:=1 to r do a:=a*10;
if(r<0) then for i:=1 to abs(r) do a:=a/10;
writeln(a)
end.
- 20.03.2017 16:19
- thumb_up 45
Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadReal('Введите число:');
var k:=ReadInteger('Введите величину сдвига десятичной точки:');
a:=a*10**k;
a.Println
end.
Примеры
Введите число: 12345.09876
Введите величину сдвига десятичной точки: -3
12.34509876
Введите число: 345.09876
Введите величину сдвига десятичной точки: 4
3450987.6
Введите число: 12345.09876
Введите величину сдвига десятичной точки: 8
1234509876000
Введите число: 12345.09876
Введите величину сдвига десятичной точки: 15
1.234509876E+19
Введите число: 1.23456789e-10
Введите величину сдвига десятичной точки: -25
1.23456789E-35
- 21.03.2017 10:17
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.