Вопрос по информатике:
Напишите программу на ПАСКАЛЕ, которая вводит последовательность целых чисел, заканчивающихся нулем, и определяет количество четных положительных чисел в этой последовательности.
Только не надо с других сайтов брать.
- 11.05.2018 03:37
- Информатика
- remove_red_eye 16525
- thumb_up 6
Ответы и объяснения 2
var
a,n,i,z:integer;
begin
readln(n);
z:=0;
for i:=1 to n do begin
readln(a);
if(a>0) then
if(odd(a)=False) then inc(z);
end;
writeln(z);
end.
- 12.05.2018 19:49
- thumb_up 40
begin
write('Введите число: ');
readln(a);
while a0 do
begin
if(a>0) and (a mod 2 = 0) then inc(p);
write('Введите число: ');
readln(a)
end;
writeln('Количество чётных положительных чисел: ',p)
end.
- 13.05.2018 18:56
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.