Вопрос по информатике:
Пожалуйста, помогите!!!
Составить программу на языке Паскаль, которая запрашивает у пользователя некоторое количество трехзначных чисел и выводит на экран цифру, находящуюся в середине каждого полученного числа.
Не в коем случае не используй их: last, Const, count. Делай обыкновенным способом.
- 17.02.2018 20:52
- Информатика
- remove_red_eye 16317
- thumb_up 31
Ответы и объяснения 2
a: array [1..255] of integer;
function sr(i: integer):string;
begin
sr:=inttostr(i)[2];
end;
begin
writeln('Vvedite kol-vo chisel');
read(x);
for i:=1 to x do read(a[i]);
writeln();
for i:=1 to x do writeln(sr(a[i]));
end.
- 18.02.2018 19:53
- thumb_up 6
var
a, b, c: real;
procedure n_1;
begin
if ((ac)) or ((ab)) then
write (a)
else
if ((bc)) or ((ba)) then
write (b)
else
if ((c write (c);
end;
begin
writeln ('Введите три трёхзначных числа');
readln (a);
readln (b);
readln (c);
if ((a >= 100) and (a <= 999) and (a b) and (a c)) and ((b >= 100) and (b <= 999) and (b a) and (b c)) and ((c >= 100) and (c <= 999) and (c a) and (c b)) then n_1
else
write ('ERROR');
end.
- 19.02.2018 21:28
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.