Вопрос по информатике:
Составьте программу, которая последовательно запросит 10 целых чисел и в результате сообщит, сколько среди введенных чисел четных и сколько нечетных чисел.
- 15.12.2017 03:37
- Информатика
- remove_red_eye 15198
- thumb_up 42
Ответы и объяснения 2
begin
writeln('Введите 10 целых чисел');
readln(q,w,e,r,t,y,u,i,o,p);
s:=0;
a:=0;
for l:=0 to 9 do
begin
if l=0 then if q mod 2=0 then s:=s+1 else a:=a+1;
if l=1 then if w mod 2=0 then s:=s+1 else a:=a+1;
if l=2 then if e mod 2=0 then s:=s+1 else a:=a+1;
if l=3 then if r mod 2=0 then s:=s+1 else a:=a+1;
if l=4 then if t mod 2=0 then s:=s+1 else a:=a+1;
if l=5 then if y mod 2=0 then s:=s+1 else a:=a+1;
if l=6 then if u mod 2=0 then s:=s+1 else a:=a+1;
if l=7 then if i mod 2=0 then s:=s+1 else a:=a+1;
if l=8 then if o mod 2=0 then s:=s+1 else a:=a+1;
if l=9 then if p mod 2=0 then s:=s+1 else a:=a+1;
end;
writeln('Чётных: ',s);
writeln('Нечётных: ',a);
end.
- 16.12.2017 16:19
- thumb_up 45
Внимание! Если программа не работает, обновите версию!
begin
var a:integer;
var (ke,ko):=(0,0);
for var i:=0 to 9 do begin
Write('Введите число ',i+1,': '); Read(a);
if a.IsEven then ke+=1 else ko+=1
end;
Writeln('Нечетных чисел ',ko,', четных ',ke)
end.
Пример
Введите число 1: 45
Введите число 2: -25
Введите число 3: 8
Введите число 4: 0
Введите число 5: 16
Введите число 6: 37
Введите число 7: 111
Введите число 8: -5345
Введите число 9: 23
Введите число 10: 15
Нечетных чисел 7, четных 3
- 17.12.2017 23:59
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.