Вопрос по информатике:
Напишите программу, которая заполняет массив из N=10 случайными числами в диапазоне {100;300} и выводит его на экран. После этого на экран выводятся средние цифры(число десятков) всех чисел, записанных в массив.
Пример:
Массив: 142 324 135 257
Число десятков: 4 2 3 5
- 20.10.2017 03:18
- Информатика
- remove_red_eye 2310
- thumb_up 26
Ответы и объяснения 2
var a: array [1..n] of integer;
i: integer;
begin
for i:=1 to n do
a[i]:=random(100,300);
writeln (a);
for i:=1 to n do
write (a[i] div 10 mod 10,' ')
end.
- 21.10.2017 02:55
- thumb_up 36
//Версия 3.3.5, сборка 1650
begin
write('массив: ');
var a:=ArrRandom(10,100,300).Println;
write('число десятков: ');
a.ForEach(x->write(x.ToString[2],' '));
end.
- 22.10.2017 04:54
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.