Вопрос по информатике:
Помогите, пожалуйста. Но только решение должно быть не через массив, а через циклы (либо repeat, либо for, либо while).
Задание: Последовательно вводится N целых чисел. Найдите минимальное и максимальное число из введенных чисел.
- 06.07.2018 02:06
- Информатика
- remove_red_eye 5980
- thumb_up 11
Ответы и объяснения 1
begin
write('Введите количество чисел (N): ');
readln(n);
write('Введите число: ');
readln(a);
max:=a;
min:=a;
for i := 1 to n-1 do
begin
write('Введите число: ');
readln(a);
if a>max then max:=a;
if a
writeln('Максимальное число в последовательности: ',max);
writeln('Минимальное число в последовательности: ',min)
end.
- 07.07.2018 07:26
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.