Вопрос по информатике:
Дан массив из 10 целых чисел в диапазоне [-10000,10000]. Определите максимальный элемент, кратный 5. Если таких элементов нет, выведите "-1".
Числа вводятся с клавиатуры. Программу выполнить в ПАСКАЛЬ.АВС
- 20.02.2018 05:42
- Информатика
- remove_red_eye 14770
- thumb_up 35
Ответы и объяснения 2
- 21.02.2018 12:29
- thumb_up 32
Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadSeqInteger(10).Where(t->(t mod 5=0)).ToArray;
if a.Count=0 then Writeln(-1) else Writeln(a.Max)
end.
- 22.02.2018 12:56
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.