Вопрос по информатике:
Составьте программу, определяющую,оканчивается ли данное чосло цифрой 4
- 11.04.2018 16:30
- Информатика
- remove_red_eye 9998
- thumb_up 42
Ответы и объяснения 2
//Версия 3.3.5, сборка 1650
begin
var n:=ReadInteger('n=');
write(n mod 10=4 ? 'число оканчивается на 4' : 'число не оканчивается на 4');
end.
- 12.04.2018 18:27
- thumb_up 21
namespace Application1{ class Program { static bool EndsWith4(int value) { return value % 10 == 4; }
static void Main(string[] args) { int value; string s; do { Console.Write("Число: "); s = Console.ReadLine(); } while (!Int32.TryParse(s, out value)); Console.WriteLine(EndsWith4(value) ? "Оканчивается на 4" : "Не оканчивается на 4"); } }}
- 14.04.2018 00:39
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.