Вопрос по информатике:
Помогите пожалуйста
1) составьте программы к задачам
Определить, является ли введённое число двузначным ( число любое 2х значное)
2)вывести 20 первых чисел, так чтобы
Каждое последующее было на 1 меньше предыдущего первое число : -2
3) Сколько нулей в записи десятичного числа 555 в двоичной системе счисления?
4) необходимо ввести некоторое целое число и, если оно четное, уменьшить его в 2 раза
5)Вывести 10 первых чисел , так чтобы каждое последующее было на 10 больше предыдущего первое число: -2
6) Сколько единиц в записи десятичного числа 600 в двоичной системе счисления ?
- 12.07.2018 00:30
- Информатика
- remove_red_eye 7970
- thumb_up 49
Ответы и объяснения 1
1)Program A;
Var a:Integer;
Begin
Write('Введите двузначное число');
Read(a);
If (a>10) and (a<100)
Then
Writeln('Число является двузначным')
Else
Writeln('Вы ввели не двузначное число!');
End.
2)var
i,a:integer;
begin
a:=2;
for i:=1 to 20 do
begin
a:=a-1;
writeln(a);
end;
end.
3)Там можно и самому просто дели 555 на 2 как можно больше чтоб конечный ответ был 2/2=0 и там считай уже
4)program b;
var a:integer;
begin
write('Введите любое четное число= ');
read(a);
if a mod 2 = 0
then
write('Ответ= ',a/2)
else
write('Было введено нечетное число!');
end.
5)program d;
var i,a:Integer;
begin
a:=2;
for i:=1 to 20 do
begin
a:=a+10;
writeln(a);
end;
end.
6)Его надо делать так же как число и 555 а ответ вообще 4 единицы
- 13.07.2018 11:08
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.