Вопрос по информатике:
Составьте программу вычисления в массиве B максимального среди отрицательных элементов и его номера.
- 16.06.2018 22:00
- Информатика
- remove_red_eye 17762
- thumb_up 15
Ответы и объяснения 2
B:array[1..N] of integer;
begin;
writeln('Сколько элементов в последовательности?');
readln(N);
writeln('Введите элементы массива');
for i:=1 to N do
begin
readln(B[i]);
if B[i]>max then
begin
max:=B[i];
k:=i
end;
writeln('Наибольший элемент последовательности = ',max,'. А его порядковый номер ', k);
end.
- 17.06.2018 13:42
- thumb_up 34
var
b,a:array [1..k] of integer;
i,m,n,k1:integer;
begin
for i:= 1 to k do
b[i]:= Random(-15,15);
writeln(b);
for i:=1 to k do
if (b[i]<0) then
begin
m:=b[i];
n:=i
end;
for i:=1 to k do
if (b[i]m) then
begin
m:=b[i];
n:=i
end;
for i:=1 to k do
if (b[i]<0) and (b[i]=m) then
begin
k1:=k1+1;
a[k1]:=i
end;
writeln ('Максимальный отрицательный элемент ',m);
if k1>1 then
for i:=1 to k1 do writeln ('Номер максимального отрицательного элемента ',a[i])
else writeln ('Номер максимального отрицательного элемента ',n)
end.
Пример:
[5,8,-11,4,-6,-3,-8,10,15,13,11,-2,0,-5,-14,11,-1,-7,15,-12,-11,5,-2,15,11,0,1,7,8,14]
Максимальный отрицательный элемент -1
Номер максимального отрицательного элемента 17
Пример:
[14,-4,5,-1,-14,4,-3,9,7,-15,1,9,11,-10,-1,4,1,-10,6,-13,-10,-5,1,9,9,-9,-7,-2,9,12]
Максимальный отрицательный элемент -1
Номер максимального отрицательного элемента 4
Номер максимального отрицательного элемента 15
- 18.06.2018 06:38
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.