Вопрос по информатике:
Составить программу которая в массиве а 12 находит среднее арифметическое
- 21.04.2016 17:01
- Информатика
- remove_red_eye 20277
- thumb_up 13
Ответы и объяснения 2
a:array [1..12] of integer;
i,s:integer;
begin
for i:= 1 to 12 do
a[i]:= Random(10);
writeln(a);
for i:=1 to 12 do s:=s+a[i];
writeln('Среднее арифметическое всех элементов массива равно ',s/12:0:3)
end.
Пример:
[7,8,9,8,4,5,7,6,9,5,6,1]
Среднее арифметическое всех элементов массива равно 6.250
- 22.04.2016 20:33
- thumb_up 18
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(12,-50,50); a.Println;
Writeln('Среднее арифметическое: ',a.Average)
end.
Пример
30 34 4 -13 35 2 31 -23 -30 44 4 -37
Среднее арифметическое: 6.75
- 23.04.2016 08:12
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.