Вопрос по информатике:
(Паскаль) Написать программу которая запросит ввести с клавиатуры 3 числа и выведит на экран большее из них. Если числа равны программа должна вывести надписть, что числа равны.
- 20.09.2017 04:37
- Информатика
- remove_red_eye 18283
- thumb_up 9
Ответы и объяснения 2
uses CRT;
var a,b,c,max:longint;
begin
readln(a);
readln(b);
readln(c);
max:=a;
if b>max then
max:=b;
if c>max then
max:=c;
if (a=b)and(b=c)and(a=c) then
writeln('Числа равны')
else
writeln(max);
end.
- 21.09.2017 21:52
- thumb_up 27
//Версия 3.3.5, сборка 1650
begin
var (a,b,c):=ReadReal3;
if (a=b) and (b=c) then write('числа равны') else write(max(max(a,b),c));
end.
- 22.09.2017 23:15
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.