Вопрос по информатике:
Определите значение переменной с после исполнения данного алгоритма.
a:= 10
a:= (a + 3) – a – a
b:= 21 + a*a
c:= b/a + 15
Порядок действий соответствует правилам арифметики. В ответе укажите одно число – значение переменной с.
- 10.09.2015 12:11
- Информатика
- remove_red_eye 5081
- thumb_up 49
Ответы и объяснения 1
a:= (10 + 3) – 10 – 10 => a=-7
b:= 21 + (-7)*(-7) => b=70
c:= 70/(-7) + 15 => c=5
Код в Паскале:
program hgj;
var
a, b, c: real;
begin
a := 10;
a := (a + 3) - a - a;
b := 21 + a * a;
c := b / a + 15;
writeln(c);
end.
- 11.09.2015 02:02
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.