Вопрос по информатике:
Паскаль
Напишите программу, которая выводит на экран массив В в одну строку и определяет количество четных и количество нечетных элементов.
- 23.02.2018 06:39
- Информатика
- remove_red_eye 16686
- thumb_up 38
Ответы и объяснения 1
Внимание! Если программа не работает, обновите версию!
begin
var b:=ArrRandom(ReadInteger('n='),-50,50); b.Println;
Writeln('Четных элементов ',
b.Where(t->t.IsEven).Count,
', нечетных ',
b.Where(t->t.IsOdd).Count)
end.
Пример
n= 20
-18 -1 48 -31 -18 -34 -42 20 -30 14 -16 45 50 0 -18 39 45 19 -10 16
Четных элементов 14, нечетных 6
- 24.02.2018 17:07
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.