Вопрос по информатике:
Паскаль.
Напишите программу, которая запрашивает ввод массива B и выводит на экран его элементы в табличной форме:
1 2 3 4
2 3 4 5
3 4 5 6
Выведите на экран среднее арифметическое элементов массива B.
- 10.03.2018 12:16
- Информатика
- remove_red_eye 1263
- thumb_up 26
Ответы и объяснения 1
Внимание! Если программа не работает, обновите версию!
begin
var (m,n):=ReadInteger2('Количество строк и столбцов в массиве:');
var b:=ReadMatrInteger(m,n);
b.Println(4); Writeln(4*b.ColCount*'-');
Writeln('Ср.арифм. равно ',b.ElementsByRow.Average)
end.
Пример
Количество строк и столбцов в массиве: 3 4
1 2 3 4
2 3 4 5
3 4 5 6
1 2 3 4
2 3 4 5
3 4 5 6
----------------
Ср.арифм. равно 3.5
- 11.03.2018 10:00
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.