Вопрос по информатике:
Программисты помогите! надо написать программу на паскале, найти произведение отрицательных элементов массива.
- 27.08.2017 08:34
- Информатика
- remove_red_eye 14556
- thumb_up 7
Ответы и объяснения 2
var a: array[1..10] of integer;
i,p: integer;
begin
randomize;
write('массив: ');
p:=1;
for i:=1 to 10 do
begin
a[i]:=random(21)-10;
write(a[i],' ');
if a[i]<0 then p:=p*a[i];
end;
writeln;
write('произведение отрицательных: ',p)
end.
- 28.08.2017 17:30
- thumb_up 15
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
a.Where(t->tp*q).Println
end.
Пример
n= 15
-44 -33 -7 48 14 44 -14 -14 -45 -13 16 47 -48 19 -14
-783151649280
- 29.08.2017 01:54
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.