Вопрос по информатике:
Напишите программу, которая находит произведение двух наименьших чисел из последовательности натуральных чисел. Программа получает на вход натуральные числа, количество чисел неизвестно (но не менее двух), ввод последовательности заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Значения чисел не превышают 30000. Программа должна вывести одно число: произведение двух чисел, значения которых в данной последовательности наименьшие
- 10.01.2017 08:51
- Информатика
- remove_red_eye 16095
- thumb_up 22
Ответы и объяснения 1
//Версия 3.3.5, сборка 1650
begin
var a:=ReadSeqIntegerWhile(x->x0).ToList;
var m:=a.Min;
a.Remove(m);
write(m*a.Min);
end.
- 11.01.2017 04:34
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.