Вопрос по информатике:
Pascal / C++
На вход программе подаются два целых числа: n и m, каждое в отдельной строке 0 < n <= 12 0 <= m < 60, указывающие момент времени "n часов m минут". Определите наименьшее число полных минут, которое должно пройти до того момента, когда часовая и минутная стрелки ни циферблате совпадут, не обязательно на каком-то делении. Вещественную арифметику не использовать.
Задачу необходимо решить без использования условных операторов (в том числе без тернарного оператора ?: в С++) и\или циклов. Кроме того нельзя использовать операции сравнения и логический (булевский) тип данных.
Примеры
входные данные
2
50
выходные данные
26
входные данные
3
0
выходные данные
16
- 11.09.2018 18:05
- Информатика
- remove_red_eye 3893
- thumb_up 7
Ответы и объяснения 1
// минутная стрелка: 1 мин - 6 град
// m*6+k*6-360 = (n*60+m+k)/2
var n,m,k:integer;
begin
readln(n);
readln(m);
k:=(60*n-11*m+720) mod 360 div 11;
writeln(k);
end.
Пример:
2
50
26
- 12.09.2018 02:35
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.