Вопрос по информатике:
Напишите программу: Посчитать количество четных цифр в числе, введенном с клавиатуры. pascal
- 16.08.2018 18:17
- Информатика
- remove_red_eye 5649
- thumb_up 48
Ответы и объяснения 2
Внимание! Если программа не работает, обновите версию!
begin
var (n,k):=(Abs(ReadInteger('n=')),0);
if n=0 then k:=1
else
while n>0 do begin
if (n mod 10).IsEven then k+=1;
n:=n div 10
end;
Writeln('Четных цифр: ',k)
end.
Пример
n= -623451
Четных цифр: 3
- 17.08.2018 20:33
- thumb_up 21
a, b, k : integer;
begin
k := 0;
write('введите число: ');
readln(a);
while a 0 do
begin
b := a mod 10;
if b mod 2 = 0 then inc(k);
a := a div 10
Writeln ('Чётных: ', a);
end;
end.
- 18.08.2018 03:33
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.