Вопрос по информатике:
Написать программу для вывода первых 10 чисел делящихся без остатка на 3 рандомные неповторяющиися числа (C#)
- 19.08.2017 08:30
- Информатика
- remove_red_eye 9273
- thumb_up 34
Ответы и объяснения 1
using System;
class Program {
static void Main() {
var r = new Random();
int[] a = new int[3];
for (int i = 0; i < 3; i++) {
int e = 1; bool t = true;
while (e != 0 && t){
e = r.Next(1, 11);
for (int j = 0; j < 3; j++)
if (e == a[j]) { t = true; break; } else t = false;
}
a[i] = e;
Console.Write(a[i] + " ");
}
Console.WriteLine();
int[] m = new int[10]; int b = 0;
for (int i = 0; i < 10; i++) b % a[2] != 0) b++;
m[i] = b;
b++;
Console.Write(m[i]+" ");
Console.Read();
}
}
- 20.08.2017 07:29
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.