Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3 и оканчивающихся на 2. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3 и оканчивающееся на 2.
- 06.12.2017 06:47
- Информатика
- remove_red_eye 2356
- thumb_up 43
Ответы и объяснения 2
n,i,a,k:integer;
s:string;
begin
readln(n);
for i:=1 to n do
begin
read(a);
str(a,s);
if ((s[length(s-1)]='2')and((a mod 3)=0))then k:=k+1;
end;
writeln(k);
end.
- 07.12.2017 20:11
- thumb_up 42
//Версия 3.3, сборка 1634
begin
write(ReadSeqInteger(ReadInteger).Where(x->(x mod 3=0) and (x mod 10=2)).Sum);
end.
- 08.12.2017 12:30
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.