Вопрос по информатике:
4. Составить программу для решения следующей задачи.
(Уровень А):
Даны катеты прямоугольного треугольника a и b. Найти его площадь S=½*a*b.
(Уровень B):
Дано целое число. Если оно кратно 3, то удвоить его. В противном случае уменьшить его на величину остатка отделения этого числа на 3. Вывести полученное число.
(Уровень C):
Найти сумму положительных нечетных чисел, меньших 100.
- 17.03.2015 12:45
- Информатика
- remove_red_eye 10237
- thumb_up 10
Ответы и объяснения 1
Уровень А
#include
using namespace std;
int main(){
int a,b;
cin >>a >> b;
double s = 0.5 * a * b;
cout << s << endl;
return 0;
}
Уровень B
#include
using namespace std;
int main(){
int n;
cin >> n;
(n%3==0) ? n*2 : n+n%3;
cout << n << endl;
return 0;
}
Уровень C
#include
using namespace std;
int main(){
int summa = 0;
for(int i = 1; i < 100; i+=2){
summa += i;
}
cout << summa << endl;
return 0;
}
- 18.03.2015 22:55
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.