Вопрос по информатике:
ОЧЕНЬ СРОЧНО!! Составить программу,формирующую произвольный массив(с помощью функции Random) из 40 элементов. Все элементы,большие 50,заменить на -6
- 10.04.2016 13:44
- Информатика
- remove_red_eye 8033
- thumb_up 45
Ответы и объяснения 1
var a: array [1..Sz] of integer;
N: integer;
i: integer;
k:integer;
begin
k:=50;
N := 40;
for i:=1 to N do
a[i] := Random(100);
writeln('Элементы массива: ');
for i:=1 to N do write(a[i],' ');
writeln();
begin
for i:=1 to n do begin
if a[i] > N then
a[i] := -6 end;
writeln('Заменяем элементы > 50 на -6: ');
for i:=1 to N do
write(a[i],' ');
writeln();
end;
end.
- 11.04.2016 00:17
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.