Вопрос по информатике:
Напишите программу которая определяет Верно ли что введенное число содержит по крайней мере две одинаковые цифры возможно не стоящие рядом
- 27.02.2016 18:16
- Информатика
- remove_red_eye 10260
- thumb_up 7
Ответы и объяснения 1
На языке С++:
#include
using namespace std;
string s;
int main ()
{
cin >> s;
for (int i = 0; i < s.size(); ++ i)
{
for (int j = i; j < s.size(); ++ j)
{
int a = s[i] - '0';
int b = s[j] - '0';
if (a == b)
{
cout << "YES";
return 0;
}
}
}
cout << "NO";
}
- 28.02.2016 12:56
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.