Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет минимальное четное число.
Программа получает на вход кол-во чисел в последовательности, а затем сами числа. В последовательности всегда имеется четное число. Кол-во чисел не превышает 1000. Введеные числа не превышают 30000.
Программа должна вывести одно число - минимальное четное число.
Паскаль
- 06.06.2018 13:16
- Информатика
- remove_red_eye 19136
- thumb_up 5
Ответы и объяснения 1
a,m,k,i: integer;
begin
write('Введите количество чисел в последовательности: ');
readln(k);
m:=30000;/// Максимальное чётное число
for i := 1 to k do
begin
write('Введите число: ');
readln(a);
if (a mod 2 = 0) and (m>a) then m:=a
end;
writeln('Минимальное четное число в последовательности: ',m)
end.
- 07.06.2018 02:53
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.