Вопрос по информатике:
Написать программу, определяющую сумму/количество элементов массива, кратных 3, но не кратных 5.
на языке С++
- 10.11.2017 06:51
- Информатика
- remove_red_eye 16540
- thumb_up 20
Ответы и объяснения 1
#include
#include
using namespace std;
const size_t N = 10;
int main()
{
size_t sum = 0;
array a = { 1, 5, 9, 6, 3, 0, 1, 4, -2, 15 };
cout << "Count: ";
cout << accumulate(a.cbegin(), a.cend(), 0, [&sum](size_t count, const int
num) {
if ( !(num % 3) && num % 5 ) {
++count;
sum += num;
}
return count;
});
cout << " Sum: " << sum << endl;
}
- 11.11.2017 14:38
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.