Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программаполучает на вход количество чисел в последовательности, а потом сами числа. В последовательности всегда имеется число, кратное 3. Количество чиел не превышает 1000. Введёные числа не превышают 30000. Программа должна вывести одно число - минимальное число, кратное 3. в С++
- 25.09.2015 21:14
- Информатика
- remove_red_eye 4399
- thumb_up 33
Ответы и объяснения 1
using namespace std;
int main()
{
int Count, Min, num;
cin >> Count;
Min = 30000;
for(int i = 0; i < Count; ++i){
cin >> num;
if(num % 3 == 0 && num < Min){
Min = num;
}
}
cout << Min;
return 0;
}
- 26.09.2015 09:45
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.