Вопрос по информатике:
Задача:
Подсчитать сумму 1!+ 2! + 3! +...N!
Где, например, 5! --факториал числа 5 и 5! = 1*2*3*4*5
Формат ввода:
На вход подается натуральное число n не превосходящих 10.
Формат вывода:
Целое число - результат вычисления формулы.
Пример входных данных
5
Пример выходных данных
153
- 01.07.2018 05:43
- Информатика
- remove_red_eye 4948
- thumb_up 14
Ответы и объяснения 1
var i, R: integer;
begin
R := 1;
For i:= 1 to N do
R := R * i;
Factorial := R;
end;
Var
N, i, S: integer;
Begin
ReadLn(N);
S := 0;
For i:= 1 to N do
S := S + Factorial(i);
WriteLn(S);
End.
- 03.07.2018 00:28
- thumb_up 27
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.