Вопрос по информатике:
На с++
Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел.
Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .
Выходные данные
Программа должна вывести в одной строке элементы массива, отсортированного в порядке возрастания последней цифры в десятичной записи чисел, разделив их пробелами. Числа, у которых последняя цифра одинаковая, должны быть выведены в том же порядке, в котором они стояли в исходной последовательности.
Примеры
входные данные
6
219 234 890 81 73 96
выходные данные
890 81 73 234 96 219
- 11.08.2018 00:04
- Информатика
- remove_red_eye 3554
- thumb_up 31
Ответы и объяснения 1
#include
#include
#include
using namespace std;
int main()
{
size_t N;
cin >> N;
vector a(N);
for (size_t i = 0; i < N; ++i)
cin >> a[i];
sort(a.begin(), a.end(), [&] (const int &z, cinst int&x) {
return z % 10 < x % 10; });
for (const auto &i : a)
cout << i << " ";
}
- 12.08.2018 06:10
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.