Вопрос по информатике:
Напишите программу которая вводит натуральное число n и выводит n квадратов из символов "@".
Ввод:
3
Вывод:
@@@ @@@ @@@
@ @ @ @ @ @
@@@ @@@ @@@
- 27.05.2018 15:27
- Информатика
- remove_red_eye 7092
- thumb_up 18
Ответы и объяснения 1
PROGRAM Solution(INPUT, OUTPUT);
VAR
n: INTEGER;
I: INTEGER;
Str: STRING;
BEGIN
WRITE('Введите кол-во квадратов: ');
READLN(n);
STR := '@@@ ';
FOR I := 2 TO n
DO
BEGIN
Str := Str + COPY(Str, 1, 4);
END;
WRITELN(Str);
WRITELN(Str);
WRITELN(Str);
END.
- 28.05.2018 15:37
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.