Вопрос по информатике:
Паскаль.
На вход программе подаётся натуральное число n<=1000. Выведите количество делителей числа n, включая 1 и само число n. (Помогите пожалуйста)
- 14.09.2016 04:56
- Информатика
- remove_red_eye 5186
- thumb_up 12
Ответы и объяснения 1
begin
write ('Введите натуральное число (n<=1000): ');
readln (n);
k:=0;
for i:=1 to n do
if n mod i = 0 then k:=k+1;
writeln('Количество делителей числа ',n,' равно: ',k)
end.
- 15.09.2016 15:16
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.