Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число — количество чисел, кратных 3.
Пример работы программы:
Входные данные:3,12,26,24
Выходные данные:2
- 26.07.2018 19:16
- Информатика
- remove_red_eye 6668
- thumb_up 25
Ответы и объяснения 2
Begin
read(n);
k:=0;
For var i:=1 to n do
begin
read(a);
if (a mod 3 =0) then k:=k+1;
end;
Writeln(k);
End.
- 27.07.2018 16:57
- thumb_up 22
using namespace std;
int main()
{
size_t N = 0, val = 0, count = 0;
cin >> N;
if (N < 100) {
for(size_t i = 0; i < N; ++i) {
cin >> val;
if (val < 300) {
if (!(val % 3)) ++count;
} else {
cout << "Value must be < 300" << endl;
exit(1);
}
}
} else {
cout << "N must be < 100" << endl;
}
cout << "Count: " << count << endl;
return 0;
}
- 28.07.2018 09:15
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.