Вопрос по информатике:
1. Составьте программу вычисления в массиве A(N) суммы всех чисел, кратных 8. 2. Составьте программу вычисления в массиве B(8) суммы четных элементов. ПОМОГИТЕ ПОЖАЛУЙСТА на Паскале
- 10.09.2018 08:20
- Информатика
- remove_red_eye 15866
- thumb_up 40
Ответы и объяснения 1
var A:array[1..100]of integer;
i,summa,n:integer;
begin
randomize;
Write('N='); Readln(N);
for i:=1 to n do begin A[i]:=random(100); Writeln(A[i]); end;
for i:=1 to n do begin
if A[i] mod 8 = 0 then Summa:=Summa + A[i];
end;
Writeln('Сумма=', Summa);
end.
2-задача
var B:array[1..8]of integer;
summa,i:integer;
begin
randomize;
for i:=1 to 8 do begin B[i]:=random(100); Writeln(B[i]); end;
for i:=1 to 8 Do begin
if odd(b[i]) then Summa:=Summa+B[i];
end;
Writeln('Сумма=', Summa);
end.
- 11.09.2018 01:08
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.