Вопрос по информатике:
Написать программу к задаче: Дано число. Найти сумму и произведение его цифр.
- 01.04.2017 20:55
- Информатика
- remove_red_eye 1965
- thumb_up 46
Ответы и объяснения 1
var n,sum,p: integer;
begin
readln(n);
sum:=0;
p:=1;
while n0 do
begin
sum:=sum+n mod 10;
p:=p*(n mod 10);
n:= n div 10;
end;
writeln('сумма цифр: ',sum);
write('произведение: ',p);
end.
- 02.04.2017 23:00
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.